CitePayUSA Service Disruption

Incident Report for CitePayUSA

Resolved

The issue affecting access to mobile.citepayusa.com has been resolved, and services are now fully restored.

Thank you for your patience while we worked to address this issue. Please reach out to support if you experience any further issues.

We appreciate your understanding.
Posted Mar 06, 2026 - 11:30 MST

Identified

We are currently addressing a configuration update affecting access to the mobile.citepayusa.com. Resolving this issue is our top priority, and we are working to restore services as quickly as possible.

We will provide updates via email as more information becomes available.

Thank you for your understanding and support.
Posted Mar 06, 2026 - 08:32 MST
This incident affected: Online Payments (www.CitePayUSA.com Website).